Xgraph Installation ERROR - Solved

The error generated while installing xgraph in NS-2 2.34 is as follows:

dialog.c:893:7: error: argument ‘lptr’ doesn’t match prototype

The Solution for the above error is:

Change the the below line at 780 in dialog.c

while (getline(&lineptr, line)) {

to

while (getmyline(&lineptr, line)) {  

and one more change in line no. 891 in dialog.c

getline(tptr, lptr)

to

getmyline(tptr, lptr)



.......